java-package 0.27 released; IBM Java2 5.0 support added

Version 0.27 of java-package has hit the unstable archive today. Thanks to the encouraging (or maybe urging) ;-) of my colleagues in the Debian Java™ Packaging Project who still primarily run on PowerPC, support for the IBM Java2 5.0 JREs and SDKs (currently in beta) has been added with this release. Hopefully that provides some relief for PowerPC and s390 users who have been languishing in Java™ 1.4.2 land until now.

Even if your JRE or JDK version was supported by a previous version, I encourage you to repackage it with this latest java-package. A massive revision to the alternatives installations has been carried out, and users should find that all of the expected executables in a JRE or JDK bin directory now have alternatives entries installed. The exceptions would be kinit, klist, and ktab. Our handling of system preferences for Java is still being and hammered out; quite an unwieldy thing what with the alternatives and all that.

Comments

Comments powered by Disqus